lzth.net
当前位置:首页 >> 把jAvA8卸载换成了jAvA7EClipsE怎么打不开了 >>

把jAvA8卸载换成了jAvA7EClipsE怎么打不开了

检查一下你的JDK8是32位的还是64位的.32位版本的会安装至Program File(x86)目录下,而64位版本的则会安装至Program File目录下.

三种情况引发这个异常:第一种:eclipse.ini中内存设置过大的问题,修改了一下,256m改成128m,把512m改为256m,即可.原因:大内存的配置导致的.第二种:在eclipse.ini中,增加了如下两行后,问题解决:-vmD:/ProgramFiles/Java/

从错误消息看它尝试使用了 jre6 目录下的 jdk.一个办法是创建快捷方式,eclipse.exe -vm %jdk8%\bin\javaw.exe 另一个办法是修改 eclipse.ini 在 -openfile 后面加上 -vm 《换行》%jdk8%\bin\javaw.exe还有一个办法,修改 java_home 变量.当你有多个程序,每个程序都使用不同的 jdk 时,修改快捷方式和 eclipse.ini 是不错的,而当你有多个 workspace 需要使用不同的 jdk 时,修改 eclipse.ini 似乎也不是最好的.顺便说一下,建议把java 安装在一个没有空格和汉字的目录下.

个人觉得没有必要卸载;之前是用java7,现在安装了java8,机器当前的JAVA相关环境变量设成8了;删除JAVA7,某些应用程序的配置可能继续指向java7的安装路径的时候,将报错.

把Workspace文件夹删除掉然后再打开Eclipse

java 8 update25是JDK的最新版本eclipse无需安装,你可能搞错版本了

感觉应该是eclipse不支持jdk1.8,应该是版本不匹配造成的,你切换到1.7的jdk再试试,而且你这个有中文路径,建议改成英文的

右键项目-properties-java build path-libraries-add library-选择jre system library然后选择你的java7路径

1.把jdk7卸载,安装JDK82.修改环境变量里面的JAVA_HOME(你是通过JAVA_HOME配置的话)

eclipse 程序有卸载功能的啊 到目录下找卸载文件吧.可以找一个不安装的eclipse 解压就可以用了..还不能用 请卸载你的jdk 重新安装.

网站首页 | 网站地图
All rights reserved Powered by www.lzth.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com