lzth.net
当前位置:首页 >> 低版本xCoDE 开发的App可以在 高版本ios上运行吗 >>

低版本xCoDE 开发的App可以在 高版本ios上运行吗

方法如下:1. 打开老的Xcode安装路径(你可以去 Apple Dev Center 下载老版本的Xcode dmg包,解压出来对应的SDK包.):Applications/Xcode.app/Contents/Developer/Platforms /iPhoneOS.platform/Developer/SDKs .这个路径中安装了你当前

首先,XCode 5本身就是在os x上面的编程软件,不存在跨平台的问题,如果你在一台mac上编写了一个iOS软件,在另一天也装了xcode 5的苹果电脑上是可以运行的,(mac通过simulator运行)那么自己编的iOS软件可不可以在自己的iPhone 和 iPad上面运行呢?本身是不允许的,除非你买了apple的developer account,99美金一年,允许你在自己的iPHone,iPad上测试,也允许你在iTunes上面发布和出售自己的app.

iPhone的大部分应用程序能在iPad上运行,ios系统的程序在设备间是兼容的.自己编的iOS软件可不可以在自己的iPhone 和 iPad上面运行呢?本身是不允许的,除非你买了apple的developer account,99美金一年,允许你在自己的iPHone,iPad上测试,也允许你在iTunes上面发布和出售自己的app.

没有差别的.不同Xcode的版本只是在功能上不同,会造成编写程序的简易程度会有一定的区别,但是如果实现一个功能都是一样的,只是高等级版本也许在语言上的优化,会使iOS应用运行的效率更高.

一般不会,xcode和iosSDK的升级确实把一些方法变成了似有方法,但是这些都会有警告提示,有些还是可以调试运行,只是不让上传到appStroe,其他都没问题.

很简单 三个办法:一种 你朋友有开发者账户的话,让他给你申请证书. (需要你的设备号 ,app id 这个尽量用* )第二种 你没办法弄到开发者账户,淘宝上买证书 , 具体价钱在10 - 20 左右. (卖家会需要你的设备号 app id 这个尽量用*)第三种 越狱 这个需要修改xcode的设置 很麻烦 不花钱 但不推荐 当时本想试试 但我系统成ios7的,当时不支持了 就没在试过了 希望能帮到你

你的程序崩溃的原因不是什么冲突,是因为你用了高版本的sdk下的方法或者属性:autolayout或者什么的,而可能你越狱的机器是低版本的,去修改程序或者storyboard文件吧,如果使用Xcode 4.5来新建项目,默认是支持AutoLayout的,但是AutoLayout是iOS 6的新特性,一般的解决方法是打开storyboard文件,去掉AutoLayout的选择.

可以选择支持的目标系统,最低可以支持到 iOS 4.3.不过开发的时候得注意不要使用到一些低版本系统不支持的 api.

不太一样,obj-c里面可以用C++,但是ios开发基本是obj-c,有一些区别

目前网上看到的教程多是XCode3的,4在界面上稍有不同,注意好SDK和ios版本,问题不大

网站首页 | 网站地图
All rights reserved Powered by www.lzth.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com