lzth.net
当前位置:首页 >> 求助大神啊,安装了JDK 1.8,以后EClipsE 打不开了... >>

求助大神啊,安装了JDK 1.8,以后EClipsE 打不开了...

把workspace文件夹删除掉 然后再打开eclipse 编辑工具中eclipse.ini文件是不是多了这个一行pluginsorg.eclipse.osgi_3.4.0.v20080605-1900.jar,把这行给删掉就可以了 jdk版本和eclipse版本是否一样都是64位的.还有你配置的环境变量是否正确

在桌面快捷方式里面,鼠标点击右键,选择属性,然后就是目标,在目标一栏处,追加参数即可解决!

你 Eclipse的版本或者JDK的版本一个是32位另一个是64位的吧

先看环境变量设置好了没有?

检查一下你的JDK8是32位的还是64位的.32位版本的会安装至Program File(x86)目录下,而64位版本的则会安装至Program File目录下.

这种情况是你没有配置jdk的环境变量,如下设置1)在系统变量里新建JAVA_HOME变量,变量值为:C:\Program Files\Java\jdk1.6.0_14(根据自己的安装路径填写)2)新建classpath变量,变量值为:.;%JAVA_HOME%\lib;%JAVA_HOME%\lib\tools.jar3)在path变量(已存在不用新建)添加变量值:%JAVA_HOME%\bin;%JAVA_HOME%\jre\bin(注意变量值之间用“;”隔开)

重新下一次eclipse吧.

不要一位的追求jdk版本,eclipse4.5版本以上才兼容1.8jdk,而且1.8的jdk安装后不需要配环境变量你把1.8的环境删除,还是用以前的,在项目里引入1.8的jdk就好了

三种情况引发这个异常:第一种:eclipse.ini中内存设置过大的问题,修改了一下,256m改成128m,把512m改为256m,即可.原因:大内存的配置导致的.第二种:在eclipse.ini中,增加了如下两行后,问题解决:-vmD:/ProgramFiles/Java/

eclipse 弹出“failed to load the jni sh原因1:给定目录下jvm.dll不存在.对策:(1)重新安装jre或者jdk并配置好环境变量.(2)copy一个jvm.dll放在该目录下.原因2:eclipse的版本与jre或者jdk版本不一致对策:要么两者都安装64位的,要么都安装32位的,不能一个是32位一个是64位.原因2的概率更大一些,原因1不太可能发生

网站首页 | 网站地图
All rights reserved Powered by www.lzth.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com