lzth.net
当前位置:首页 >> 我想问一下我现在使用的是火狐56.0.2的版本,对应... >>

我想问一下我现在使用的是火狐56.0.2的版本,对应...

新版火狐是支持selenium,但是部分用户反馈运行过程有问题,因为selenium没有更新,所以建议退回火狐到49及以下版本使用。

这个地址就可以。不过57的话可能就不支持了、addons.mozilla.org/en-US/firefox/addon/selenium-ide/ 如果没法装的话,可以直接给你.xpi文件

尽量用高点版本的selenium jar包,因为 firefox-56.0 是需要geckodriver去驱动,印象中selenium 3.0以上才开始支持geckodriver

新版火狐浏览器在扩展和插件策略进行了较大调整,出现该问题多半是因为扩展或兼容未进行兼容适配。 如果有很重要的功能需要使用,建议暂时回退浏览器版本或者使用火狐浏览器的scr版本作为临时解决方案。

删除目前安装的版本,然后下载旧版本安装就可以了,旧版本可以在火狐FTP服务器中下载,具体的网址,请自行百度。

如果不是特别需求新版本火狐,可以适当降版本,我现在降成55.0.3的,可以用firebug https://ftp.mozilla.org/pub/firefox/releases/ 火狐的历史版本

关闭火狐,在桌面按住Shift启动火狐浏览器,进入安全模式,在安全模式下测试,如果安全模式下正常,应该是扩展原因,在附加组件里分批禁用扩展排查。

确定你安装了火狐浏览器?要记得一定是安装的,直接把目录拷贝过来的话会有问题。可能你火狐的版本太低了。如果不是,你试试安装其它版本的火狐

selenium-java-2.42.2版本和firefox 29.0.1版本兼容,如果升级到firefox 30+,则浏览器启动失败。可能是selenium还未同步升级,后面估计可以正常支持。 若selenium的版本和firefox不兼容,需要升级selenium的jar包,或者是升级firefox。

网站首页 | 网站地图
All rights reserved Powered by www.lzth.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com